Getting started with PinPoint

NOTE: This not an APRS tutorial. To understand APRS capabilities and learn more about its usefulness,
please visit http://www.aprs.org or do a search on “APRS Introduction” using any major search engine

on the web.

This guide is meant as a quick and dirty configuration and features overview for PinPoint

License

PinPoint (“the software”) is free for use by individuals. No warranty is expressed or implied. By using the
software you agree to the fact that the author can in no way be held liable for any kind of damages
resulting from direct or indirect use of the software. By using the software you also agree to the fact
that you are using this software at your own risk and you understand that it should not be used in cases
where a human’s life depends on it or loss of property is at stake.

System requirements for using PinPoint

e Microsoft .NET framework 2.0 (can be downloaded from http://www.microsoft.com).

e Adobe Reader (can be downloaded from http://www.adobe.com).

e At least one COM port for your TNC and GPS, or two COM ports if connecting the GPS and the
TNC directly to your machine. Most USB to COM converters will work just fine.

e Microsoft MapPoint 2004 or MapPoint 2006.

e PinPoint has been tested with Windows XP and Windows Vista, but should run on Windows 98,
ME and 2000 as well given the above software has been installed prior to installing PinPoint.

Feedback

Under the Help menu item, you will find a Send feedback menu item. If you click on it, Pinpoint will
gather some specific system information and include it in a message body that you can add anything to
that you like (bugs, feature/enhancement requests, praise).

There is no confidential information being sent via email. Just enough to help troubleshoot in case you
are having any problems. You can certainly use the feedback button to request additional future
functionality, or just send an email with a quick question.

Once you click Send, make sure to go into your email application to Send/Receive email to ensure the
email is going out. With Outlook, if you click Send while the main Outlook screen is not open, the email
will sit in your Outbox until the next time you connect to the email server.



If you need general help with APRS (not specific to the use of Pinpoint), please use the web or your
peers as your first resource to find any possible answers.

Feedback is always welcome and can also be sent directly to pinpoint@watervoort.com

Installation

Double click on the file called Setup.exe and follow the prompts. No changes are necessary during
installation. The default installation options will install PinPoint in the c:\Program Files\PinPoint
directory. Please do not change this path, since PinPoint expects to be installed in the c:\Program
Files\PinPoint directory (for now).

Note for installing PinPoint on Microsoft Windows Vista (any edition)

When installing PinPoint on Microsoft Windows Vista, navigate to the c:\Program Files\PinPoint
directory, right click on PinPoint (application), and select the Compatibility tab from the menu. Enable
the ‘Run this program as an administrator’ option and click OK. This will allow PinPoint to change the
system time and synchronize it with the GPS. If you chose not to set this option, PinPoint will run just
fine, but it will not be able to synchronize your PC to GPS time. Not setting this option will also interfere
with logging (debugging) options.

Configuring PinPoint

Connect your TNC to your COM port. If you have a GPS, connect it to the TNC if you have a TNC that is
capable of passing through GPS data (like the Kenwood D700, D710 mobile or D7 handheld). Ensure the
GPS is set to 4800 baud (bps) and that it puts out standard NMEA sentences, which is usually the default
setting.

If you do not have a TNC that can pass through GPS NMEA sentences, you can connect the GPS directly
to your PC if you have a second COM port. A GPS with the USB port is not supported, since PinPoint
relies on NMEA sentences.

Double click on the PinPoint icon on your desktop. This should start PinPoint.
You should see four windows appear:

e PinPoint —This is the window where all configuration takes place and GPS data is displayed
e Last Heard — Provides an overview of all received APRS messages and position/weather reports



e TNC Data — Shows raw data being sent to and received from the TNC (GPS data also if using GPS
pass through capabilities. More on that later). Allows you to send commands to your TNC as
well.

e Map - The MapPoint map that shows all position, weather, direction finding, etc information

The first thing you should do is move the windows (drag them and resize them as needed) to your liking.
When you exit Pinpoint (using the File > Exit menu) PinPoint will prompt you and ask if you want to save
all windows sizes and locations. Answer YES if you would like to retain your changes for next time
PinPoint is started up.

Next, let’s configure PinPoint so you can get on the air. In principle, the only item you need to configure
is your callsign + SSID and your TNC/GPS settings. The defaults should suffice in most cases.

In the PinPoint main window (called PinPoint), select the Tools menu from the menu bar and select
Options. This will open up a new window where you can set the desired configuration.

Tools > Options > General tab

My APRS Callsign + SSID: This is your call sign + any SSID you wish to assign. An SSID (Secondary Station
Identifier) is used to uniquely identify your station in case you have multiple APRS stations. An SSID is
optional. Example: ABOWV-5.

APRS Group code: This is a group/software code that can be used for filtering purposes. Leaving it at the
default setting of APZPPT is just fine.

APRS path (Unproto): Determines the number of possible hops your packet will take. In a suburban area
WIDE1-1 should work fine. For mobile operation in a suburban area WIDE1-1,WIDE2-1 should work fine.
Outside the suburbs, WIDE1-1,WIDE2-2 is recommended.

Position comment: A comment that is sent out with every position report (beacon). Example: “Frank in
Castle Rock”

Station icon: The representation on the map that is closest to the vehicle you’re driving or building
you’re in.

Enable APRS DigiPeater: If you would like to serve as a digipeater as well, you can enable the function
by checking the box.

Enable APRS beaconing:
Beacon at least every 1800 seconds. The default is to beacon every half hour if stationary or...

Beacon at least every 3 miles. If moving, at least beacon every 3 miles or...



Beacon when my heading changes more than 35 degrees. If you are turning corners, send out a
beacon as well.

Each beacon as a result of one of the above will reset the timer, traveled distance and change in heading
as to reduce the number of beacons.

Beacon my altitude. This option, when checked, will include the altitude in your APRS position
report. You can omit it by disabling this option.

Beacon my course and speed. This option, when checked, will include the course and speed in
your APRS position report. It should be turned off if you have a stationary APRS setup.

Tools > Options > TNC tab

TNC type: Select the TNC that matches your TNC closest.

COM port: The COM port on your PC that your TNC is connected to.

Speed: The speed of your TNC. The default is set at 9600 bps.

Data bits: The number of data bits your TNC is expecting. Usually 8 bits.

Parity: The parity setting in your TNC. Usually the ‘None’ setting suffices.

Stop bits: The number of stop bits used for communicating with your TNC. Usually 1 stop bit.

Flow Control: The handshaking method used. If you have an RS-232 cable will all leads connected, try
Hardware. Otherwise, try XonXoff or None.

Send startup script when connecting TNC: Highly recommended to leave enabled. This feature
initializes your TNC when connecting to your TNC with your call sign and various other parameters
specific to APRS.

Send shutdown script when disconnecting TNC: Turns off a few features on your TNC when
disconnecting the TNC.

Connect TNC automatically when PinPoint starts: Allows you to connect immediately to your TNC when
you start PinPoint up.

Tools > Options > GPS tab

If you have a GPS that is connected to your TNC and your TNC is capable of passing the GPS data to the
PC, enable this option.



If you have a GPS connected directly to the PC, disable this option and set the right COM port and speed
to match the GPS.

Synchronize PC clock with GPS time will take the atomic-clock-based time from your GPS and
synchronize your PC to it when enabled.

Connect GPS automatically when PinPoint starts: Allows you to connect immediately to your GPS when
you start PinPoint up (only if GPS is connected directly to PC).

‘Process all GPS NMEA sentences’ versus ‘Process one type of GPS NMEA sentence’. If your PC is older
and lacks horsepower (and seems sluggish when running with the ‘Process all GPS NMEA sentences’
option enabled), you may reduce the amount of CPU required to process GPS data by selecting the
‘Process one type of GPS NMEA sentence’ option.

Please note that you will not be able to see certain types of data (including the Satellite signal strength
window) if you only process one type of GPS NMEA sentence. This option is only available for GPS units
that are connected to a TNC that passes the data through. This option does not work for GPS units that
are directly connected to the PC.

Initial Position: If you don’t have a GPS, you can manually type the Latitude and Longitude in these
fields. The first text box is for the whole degrees (always positive), the second for the minutes (decimal
up to 4 positions) and the last for the N/S or W/E designator. You may enter your altitude as well.

Tip: SHIFT-click on the map and you will see the latitude and longitude of where you clicked. You could
figure out your start position and enter it in the Initial Position fields this way. You will also notice that
when you move the mouse over the map that the title bar of the Map window will show the latitude
and longitude when the mouse is ‘hovering’.

Tools > Options > Map tab

Default map style allows you to change the various map styles available and use it as a default for
PinPoint.

Default map location is the file name of the map to use when starting up PinPoint. You could create
your own map in MapPoint and then use it as the default startup map in PinPoint this way.

Max number of breadcrumbs while tracking stations. This determines how many breadcrumbs a
tracked station will leave behind after which breadcrumbs get cleaned up. If you determine you’d like to
track a station (either individually, by right clicking on the call sign in the Last Heard window under
Position Reports; select Track from the menu that comes up, or click on the Track button in the main
PinPoint window to track all stations on the map) every time a station beacons the system will put a
blue dot (breadcrumb) on the map.



In order to keep the map clean, setting the maximum number of breadcrumbs to say ‘10’ means that
the oldest breadcrumb gets removed from the map when there are more than 10 breadcrumbs.

Draw lines between breadcrumbs will draw a line in the same color as the breadcrumb between the
breadcrumbs on the map as you track the station. This will make the track stand out more. The track
does not follow roads, but merely connects the dots (breadcrumbs).

Alternate breadcrumb and line colors between tracked stations will use different color breadcrumbs
and styles (circles, triangles, squares) and different color lines (if enabled, see previous option) between
breadcrumbs to make multiple tracked stations easier to separate on a map.

Remove position reports | haven’t heard in 90 minutes. Stations that haven’t been heard in a while will
be removed from the map (icon, breadcrumbs, lines and all) and from the Position Reports area in the
Last Heard window. You have full control over how long stations should stay on the map.

Keep map centered on my position. Keeps the map centered on your latest position using the GPS. That
way you can keep an eye on the stations around you without having to pan the map.

Highlight my position on the map makes it a little easier for you to find yourself on the map by adding a
yellow circle around your own callsign on the map.

Highlight my beacons on the map when tracking is enabled. When tracking and you receive your own
beacons, the yellow breadcrumbs that determine your own beacons are highlighted.

Center map on received position reports will center the map on the next received position report.

Draw line to stations received direct. Any station that your radio/TNC can hear directly (meaning, not
needing a digipeater) will be shown on the map as having a line drawn from your position to the station
in question. You can control the line color and line width. These lines get cleaned up automatically as
the station moves, or as the station is removed from the map as a result of the automatic time-based
map ‘cleanup’.

Plot received DF bearings on the map. PinPoint is capable of sending out Direction Finding bearings via
radio (Shift Click on the map, select Plot DF bearing) and displaying them on the map when received.
Enabling this option allows PinPoint to show any DF bearings received via APRS (PinPoint proprietary
feature and APRS experimental protocol extension). You can additionally control the line color and line
width on the map for the DF bearing.

Center map on starting point of DF bearings will center the map on the starting point of a received DF
bearing.

Tools > Options > Weather tab



You can select the various parameters you would like to see in a detailed weather text balloon on the
map (only if the parameter is available in the APRS packet).

Deflating the detailed weather data means that the text balloon with the weather data will be reduced
to a call sign only after 2 minutes. You can control the interval at which the text balloons should be
deflated.

Tools > Options > Sound tab

Here you can turn sounds on or off for the various events. You can also customize using your own sound
files.

The speech synthesizer (only available in Windows XP and Vista) will help with some announcements if
desired (GPS time, Message received).

Tools > Options > Internet tab

This tab is currently not in use and is reserved for future options

Tools > Options > Misc tab
This tab is used for miscellaneous application settings.

Assume APRS Message is for me if only SSID doesn’t match. Example: Someone send a message to
ABOWV-3, but your station is setup as ABOWV-5. PinPoint would still claim the message as yours if the
SSID doesn’t match (shows up in bold, speech synthesizer announces message).

Only show APRS messages addressed to me. Filters out any APRS messages not sent to your callsign
and doesn’t display them. By default, PinPoint shows all messages (including the ones not addressed to
you) and shows the messages addressed to you in bold.

Enabled large font mode switches various windows into large font mode for easier reading, especially
while driving.

Auto answer APRS message allows you to either always or only while you’re driving automatically send
a reply to an APRS message addressed to you. That way you can tell someone for instance you’re driving
and can’t type only when you’re actually driving. As soon as you stop, the auto answer switches off.

Default night mode color is the default font color for night mode. This does not affect the map color
(MapPoint 2006 has a night mode for the map as well. The map is shown in green with a black
background. MapPoint 2004 does not support this feature).



Pop-up Message Board window upon receipt of a post. If you do not have the Message Board window
up on your screen, enabling this item will pop it up as soon as someone posts a message to the message
board. This is a PinPoint proprietary feature and APRS experimental protocol extension.

Log all activity to a file is useful for application debugging. You may turn this feature off if you do not
encounter any instability. You may always safely remove the log.txt file in the C:\Program Files\PinPoint

directory.

To save your changes, click the OK button. To cancel and therefore not save your changes, click the
Cancel button.



Getting on the air

Tune your radio to 144.390 MHz, turn on your TNC and click the TNC button in the main PinPoint
window to connect to the TNC. You should see the raw TNC data in the TNC Data window scroll by. If
you don’t see any responses from the TNC, check your connections and settings to ensure they match
the TNC’s settings.

If your GPS is connected to your TNC, you should be seeing the Latitude and Longitude vary a little bit
every so many seconds in the main PinPoint screen. This is normal.

If you would like to see if your TNC is actually sending you GPS data, click the Show GPS button in the
TNC Data window. You should see information scroll by about every 2 seconds that starts with a dollar
sign (e.g. SGPRMC.....SGPGGA.....and others) if you accept all sentences (check your Tools > Options >
GPS settings) or just the one SGPRMS or SGPGGA sentence every so many seconds again depending on
your settings.

If your GPS is connected directly to your PC, click the GPS button in the main PinPoint window. If the
GPS button is grayed out, it means that PinPoint is set to accept GPS data through the TNC (pass through
is enabled in the Tools > Options > GPS screen).

To enable beaconing, click the Beacon button in the main PinPoint screen. It will immediately beacon a
position report, and then consequently according to your settings in Tools > Options > General. If the
Beacon button is grayed out after you connected to the TNC, it means that the beacon option in Tools >
Options > General is disabled.

To track all stations on the map, you may click the Track button in the main PinPoint window. It will
create breadcrumbs for every tracked station and clean them up according to your breadcrumb settings
in Tools > Options > Map.

You may also track individual stations by right-clicking on a callsign in the Last Heard window under
Position Reports and selecting the ‘Track on map’ option from the menu that appears when right-
clicking.

The Mute button in the main PinPoint window turns off all PinPoint sounds, which could be useful in a
situation where you suddenly need silence like watching a video or listening to an audio stream on your
PC and you need PinPoint to be quiet.

The iGate button is for future use.

Using Filters

With the use of the Filters option, you can filter out any unwanted stations to prevent your map from
getting cluttered. Take a look at the Edit > Filters option to edit your filter. Each of the options within



the filter (E.g. “Only show stations in the following groups”) can be enabled or disabled. Anything you
put in the filter will be saved for future use by clicking the OK button.

The Filter button on the PinPoint main screen activates or de-activates the filter. Filter parameters are
evaluated from the top down in the Edit Filters window.

Using Alarms

The Alarms feature will allow you to sound an alarm signal when an alarm condition is met. The alarm
conditions can be edited under Edit > Alarms and activated / de-activated using the Alarms button on
the PinPoint main screen.

You can use Alarms in combination with Filters to only alarm based on very specific conditions. Alarm
parameters are evaluated from the top down in the Edit Alarms window.

The File menu

File > Save Map allows you to save the current map including all objects for future use. PinPoint will
prompt you to remove all call signs, objects and lines from the map or not before saving. That way you
can save a certain view of the map, but not have all the station icons, lines and everything else be saved
with it.

File > Load Simulation allows you to load a raw TNC data file (which you can create using the Save
button in the TNC Data window) and replay a sequence of packets.

File > Exit shuts down PinPoint

The View menu

View > Map toggles between making the map visible or invisible

View > Map Toolbars > {toolbars} makes the various toolbars visible/invisible within the Map window
View > TNC Data window toggles between making the TNC data window visible or invisible

View > Last Heard window toggles between making the Last Heard window visible or invisible

View > Satellite Signal Strength window toggles between making the Satellite window visible or
invisible. You must accept all GPS sentences in Tools > Options > GPS for this feature to work, since it
relies on a specific GPS sentence (SGPGSV) to be passed by the GPS.



View > Message Board window toggles between making the Message Boars window visible or invisible.
The Message Board is comparable to a group chat room. Everyone can post to it and you can use the
Filters to filter out unwanted groups, call signs or even based on distance. If you reject all position less
reports, no message board postings will show up, since those packets will be rejected. To use the
Message Board, just type a message into the bottom half of the Window and press Enter or click Send.

View > Restore Initial Map view restores the map to the view at startup of PinPoint. It will not remove
any call signs, objects or lines from the map. You can also press the R key (the main PinPoint window,
the Last Heard window or the TNC Data window must be the active screen for the key shortcuts to work.
The map window intercepts these key codes for itself, and the shortcuts therefore don’t work, yet).

View > Reset All Window Sizes and Locations restores all windows to their initial (‘factory default’)
settings.

View > Switch to Night Mode switches PinPoint into night mode using the font color you set in Tools >
Options > Misc > Default night mode color. Unfortunately, the only way to revert back to normal mode
(right now) is to end and restart PinPoint. This feature also changes the map to night mode (black with
green). Changing the map to night mode is only supported by MapPoint 2006, not by MapPoint 2004.

View > Remove all lines from the map removes all lines (DF bearings, hand drawn lines, APRS direct)
from the map, but leaves everything else alone.

View > Remove all breadcrumbs from the map removes all tracking breadcrumbs from the map.

View > Clear Map removes all objects from the map (call signs, breadcrumbs, objects, lines, etc) and
leaves you with a clean map.

The Tools menu

Tools > Connect to TNC is the same as the TNC button on the PinPoint main window. It connects to the
TNC that is configured in Tools > Options > TNC.

Tools > Connect to GPS is the same as the GPS button on the PinPoint main window. It connects to the
GPS that is configured in Tools > Options > GPS. This is only for GPS units directly connected to the PC
and not for GPS units connected to the TNC for pass through.

Tools > Re-initialize TNC will send the startup TNC script to the TNC once more.

Tools > Send Message sends an APRS message. You may also right click on a callsign in the Last Heard
window under position reports and use the Send Message option. You can also select ‘New Message’
from the menu that appears when you right click on the Inbox in the Last Heard window.

Tools > Send Bulletin allows you to send an APRS bulletin, which works similar to a regular message, just
that the recipient is ‘all APRS users’.



Tools > Send Weather report allows you to send a manual weather report via APRS. Please note that if
you don’t have certain information available, leave the field blank (do not set it to zero). Rainfall needs
to be entered in 1/100 of an inch, so if you enter 20, it means 1/5”. Barometric pressure is entered in
1/10mBar, so 10000 is 1000 mBar (=1 Bar). Wind speed is entered in Mph, not in knots. When you click
Send, the weather report is broadcast over APRS immediately.

Tools > Map FindU history allows you to map the entire history (up to 24 hours) of a specific call sign on
the map. Only works when the TNC is not connected and you have Internet access available. The data is
retrieved from the FindU website. This can come in handy when you’re trying to track someone who is
no longer in radio range. To find out more about FindU, go to http://www.findu.com .

Tools > Plot DF bearing on map allows you to draw a Direction Finding triangulation line on the map and
send it out via APRS for other PinPoint users to see on their own map as well. You can also shift-click on
the map and select the Plot DF bearing on map option from the menu. You can plot a DF bearing from
your current position, from the position where you shift clicked on the map, or manually enter
coordinates in decimal degrees. You need to have the Plot Received DF bearings on map feature
enabled in Tools > Options > Map in order to receive bearings.

Tools > Options allows you to setup and change the configuration. While the TNC is connected a limited
number of parameters can be changed. To change parameters that are grayed out, disconnect the TNC
first.

Other PinPoint features
Keyboard shortcuts

The main PinPoint window, the Last Heard window or the TNC Data window must be the active screen
for the key shortcuts to work. The map window intercepts these keycodes for itself, and the shortcuts
therefore don’t work, yet.

Z - Zoom — Temporarily zooms in / out on the area currently centered on the map
R — Restore Initial Map View — Restores the map view you had when PinPoint started up
M — Minimize all pinpoint windows to the task bar

N — Night mode — Sets all windows and map to night mode. To restore non-night mode, restart PinPoint
(night mode map only supported by MapPoint 2006, not by MapPoint 2004).

B — Force beacon — Beacons immediately if the TNC is connected
F — FindU lookup — Plots FindU history on the map for the entered callsign. Requires Internet access.

P — Presbyopia mode — Changes PinPoint windows to use larger fonts



W — Reset the main PinPoint window (PinPoint, Last Heard, TNC Data, Map) sizes and locations to
factory default settings.

D — Plot DF bearing on map shortcut

APRS messages

APRS Messages show up in the Inbox in the Last Heard window. Click on a message to read it. You may
Reply, Forward or Delete right from the message window. Messages shown in bold are addressed to
you. Once you have read a message, it will no longer be shown in bold.

Right click on the Inbox to start a new message, or just right click on a call sign to create a message that
will pre-populate the recipient’s call sign.

The messages you have sent can be found in the Sent folder in the Last Heard window.

Sending commands to your TNC

Should the need arise to communicate directly with your TNC, you can type a TNC command in the text
box at the bottom of the TNC Data window and press Enter or click Send to send it to the TNC. The TNC
Data window will show the response from the TNC (if any).

Map Shift-Click

You can hold down the Shift key and click anywhere on the map to see a whole new set of options.
Latitude and Longitude of where you clicked are displayed.

The distance shown is the distance from your own position.

Set my current position to where | clicked allows you to change your own location without needing a
GPS.

Show aerial view of where I clicked will open a window and show a satellite image of the area where
you clicked on the map (Internet access required). You can zoom-in or out, or in most cases (urban
areas) you will be able to get a bird’s eye view (much more detail than satellite imagery) as well.

Get driving directions to where I clicked will immediately provide you with turn-by-turn driving
directions on how to get from your current position to where you clicked on the map. The amount of
travel time is also displayed.



Plot DF Bearing from where I clicked allows you to create DF bearing (that can be broadcast over APRS
if desired) that will be put on the map with the starting point at the location you clicked.

Add object to the map allows you to create (and broadcast) an object on the map, for instance a
meeting point that others can see o their maps. You do not need PinPoint to see the object appear on
your map. Any APRS software will interpret this object and show it on the map. The Tactical call can be
your callsign with a different SSID or anything else. Example ‘BKFAST’ or ‘SHELTER1'.

Right-Click a callsign in the Position Reports tree

You can right click on a call sign under position reports and have the following set of options.

Track on map allows you to individually toggle tracking on or off for a station. Breadcrumbs will be
shown on the map when the station in question is on the move.

Show on map moves (centers) the map to the callsign in question, just in case you couldn’t find it
before.

Show aerial view shows a satellite image of the location that the station is located at. Works the same
as the Show aerial view of where | clicked option in Map Shift-Click (previous section). Requires Internet
access.

Callsign lookup will look up the callsign in question (after stripping off the SSID) on QRZ in a new
window. Requires Internet access.

Send message will open up the compose APRS message window with the call sign in question pre-
propagated as the recipient.

Get driving directions will create turn-by-turn driving directions to get from your current location to the
location of the station in question.

Remove station removes the station from the Last Heard window (not from the map).
Sort Alphabetically will sort the entire Last Heard tree alphabetically.

Get FindU history will map the entire known FindU history on the map for the station in question (last
24 hours max, only works with TNC disconnected).

Plot DF bearing will plot a DF bearing using the location of the station you right-clicked on as the starting
point. This option is great for when the station in question is reporting his/her DF bearing via voice and
you want to plot it on a map and share it with others using PinPoint. All they would need to tell you is
their bearing. The starting point is already conveyed via APRS (make sure the station beacons to make
sure you have their latest position).



